SmartCode Web Forum

Corrupt Video Hook Driver installation via deployment wizard

By bitbyte - 19 Jan 2007

I'm currently evaluating VNC Manager (Enterprise edition) for use in our server environment.

We are using a mixture of HP Proliant servers including a C class bladecenter.

When I use VNC Manager to push an installation of UltraVNC to a server, the video hook driver doesn't install correctly. Even though the deployment wizard logs no errors during the install.

If I launch the Service Helper, right click on the icon then go to properties, the first thing I notice in the "WinVNC: Current User Properties" dialog box is that the "Video Hook Driver" box isn't checked, even though in the deployment wizard I told it to do so. If I check this box and click "OK" then go back into the properties it's unchecked again.

Additionally, if I click on the "Check Video Hook Driver" button I see that the version numbers for the 3 components listed in the "Driver Test" dialog box are garbled. You can see a screenshot of it at this link:

If I go in and manually run the driver installation batch file in the UltraVNC folder, it fixes the problem. But it's hardly a good solution for deploying to 150+ servers. I get this problem on all of the server types I've tried it on. Additionally, if I do a manual install of UltraVNC using the software downloaded from UVNC, it works fine.

I've tried this same process using both versions 3.5 and 3.6 beta with the same result.

Thanks for your input.

By Yury Averkiev (s-code) - 23 Jan 2007

Hi Tim,
we did some reasearch today and I think I can explain what is going on. But before diving into details - the reason the problem is a bug in UltraVNC 1.0.2 build.

Due to this bug the driver will install properly if at the moment of deployment there is a user who use physically logged into the remote computer. He can be logged on locally or via RDP connection. Most probably the user should use the same logon credentials as the ones use in the VNC Deployment Wizard. As you can see from the screenshot below, the graphics driver installs OK in this case.

The same bug causes the VNC server tray icon not to appear after the deployment unless there is a user who logged on to a remote computer.
We haven’t decided how to address this problem yet. There are two possible solutions:

  1. Wait for UltraVNC 1.0.3, which according to site should be released some time soon.
  2. Workaround this problem on our side. Unfortunately this would require modifying the UltraVNC source code and we don’t really want to do that. Because this bug in UltraVNC server is a tricky one we afraid that by fixing this problem we might introduce some new ones.
  3. There is actually third solution, which we are currently discussing. The solution would involve a workaround in our custom built VNC setup packages. Actually this might be the best solution, at least until v1.0.3 gets released.

We will try our best and get this issue resolved in upcoming v3.6.

By [0] - 29 Nov 2010

I am currently having the same issue as Tim and was wondering if this has ever been resolved or not.  All attempts to install the driver remotely through scripts, devcon or ConfigMgr results in a corrupt video hook driver installation "unknown device".   But as soon as you run it with the current user's logged on credentials it installs fine.  This is a deal breaker when you need to deploy it to 1,200+ system.  Any additional help would be appreciated.

By Yury Averkiev (s-code) - 2 Dec 2010

Hi Brian,
what is the OS of the remote computer and what build of the VNC manager do you use?

Personally I wouldn't use the graphics driver at all. It just reduces the system stability. It seems that guys at TightVNC have the same opinion; they no longer bundle their graphics driver with TightVNC 2.0.