Problem Using .vnc (Saved Connection Info) Files


Author
Message
Bob Hartung
Bob Hartung
Supreme Being (6.5K reputation)Supreme Being (6.5K reputation)Supreme Being (6.5K reputation)Supreme Being (6.5K reputation)Supreme Being (6.5K reputation)Supreme Being (6.5K reputation)Supreme Being (6.5K reputation)Supreme Being (6.5K reputation)Supreme Being (6.5K reputation)
Group: Forum Members
Posts: 51, Visits: 190
Sometimes I have situations where I want to give individuals remote VNC access to another PC. For example, we have a PC that serves as a digital recorder for our security IP cameras. I want to have the Plant Manager be able to launch a remote session using a .vnc file on his desktop so he can view security footage.

From the user's PC, I connect manually to the target PC using UltraVNC and then save the connection info, using the menu in UltraVNC, to a .vnc file on their desktop. However, when I try to launch the .vnc file, the PC doesn't know what application to use to launch the file. If I manually try to associate the .vnc extension with the winvnc.exe file, it still fails to launch, resulting in a UVNC error "Invalid VNC Server specified".

The reason I'm posting this problem to the SCode forum is because this is only a problem for PCs that have UVNC installed by the SCode UVNC  installation of UVNC. On PCs where I have installed UVNC using the install file downloaded from the UVNC.org website, you have the checkbox option, during install, of associating the .vnc extension with the UVNC application and .vnc files launch without problem.

I have not found any option in the SCode Install Wizard configuration for enabling .vnc extension association. Is there a way to do it?
Yury Averkiev (s-code)
Yury Averkiev (s-code)
Supreme Being (207K reputation)Supreme Being (207K reputation)Supreme Being (207K reputation)Supreme Being (207K reputation)Supreme Being (207K reputation)Supreme Being (207K reputation)Supreme Being (207K reputation)Supreme Being (207K reputation)Supreme Being (207K reputation)
Group: Administrators
Posts: 1.9K, Visits: 3.6K
Hi Bob,
our custom built UltraVNC MSI installer supports ability to associate .vnc files. But for some reason this feature is not reflected in the VNC Deployment Wizard. I'll double check on that and most likely this feature will be added to the Deployment Wizard in the next build.

http://www.s-code.com/App_Themes/Default/images/blue_line.gif
Regards,
Yury Averkiev, SmartCode

minorgod
minorgod
Supreme Being (257 reputation)Supreme Being (257 reputation)Supreme Being (257 reputation)Supreme Being (257 reputation)Supreme Being (257 reputation)Supreme Being (257 reputation)Supreme Being (257 reputation)Supreme Being (257 reputation)Supreme Being (257 reputation)
Group: Forum Members
Posts: 1, Visits: 1
I had this problem myself today on Windows 8.1 and I finally came up with a simple solution after pulling my hair out for a couple of hours. I wanted to install just the vncviewer.exe from the MSI installer downloaded from ultravnc.net, but that installer never gives you the option to associate .vnc file with the viewer, and if you let windows do it for you, it fails to pass the oh-so-important /config option to the vncviewer.exe when it launches. So, here's the super-simple fix, which I have now cross-posted on the relevant threads in the ultravnc forums too:

First, if you've already made the mistake of using the windows file type association control panel or other automated method to associate the .vnc extension with the vncviewer.exe, open regedit and do a search for ".vnc" and delete all keys you find. Then make a little batch file containing the following:

ftype UltraVnc.Connection=C:\Program Files\uvnc bvba\UltraVnc\vncviewer.exe /config %%1
assoc .vnc=UltraVnc.Connection


Then right-click the batch file and choose "Run as Administrator".
Your .vnc files should then launch the vnc viewer correctly. Please note that you may need to change the path above to point to the location of your vncviewer.exe file if it's not installed in the same place as mine. Also note, the double percent sign in "%%1" at the end of the ftype line in the .bat file is NOT a typo. You need the double percent sign when you run a command like that inside a .bat file.

Hope this helps someone.
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Explore
Messages
Mentions
Search