Enable DSM encryption in HTML


Author
Message
Bonji
Bonji
Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)
Group: Forum Members
Posts: 10, Visits: 21
I am unable to figure out how to enable encryption via the DSM plug-in.  I see the EnableSecurity property (along with KeyFilePath), but I am unable to code it properly in the example HTML file.

Sincerely,

Ben

Yury Averkiev (s-code)
Yury Averkiev (s-code)
Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)
Group: Administrators
Posts: 1.9K, Visits: 3.6K
Hi,

EnableSecurity and KeyFilePath are the only two properties that must be set. I could think of two reasons why it doesn't work:

1) Your UltraVNC server doesn't have DSM plug-in security enabled or RC4 keys mismatch on the server and client

2) For some reason ViewerX fails to load the key file specified in the KeyFilePath property.



Just to let you know, soon we will be releasing a new ViewerX build. This build will allow to set RC4 key via two new properties:



//allows you to pass RC4 key as a binary data in form of SAFEARRAY

HRESULT UVNCS_KeyData([in] VARIANT arrDsmKeyData);



//allows you to pass RC4 key as a HEX string

HRESULT UVNCS_KeyDataAsHexStr([in] BSTR strDsmKeyData);


http://www.s-code.com/App_Themes/Default/images/blue_line.gif
Regards,
Yury Averkiev, SmartCode

Bonji
Bonji
Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)
Group: Forum Members
Posts: 10, Visits: 21
I should be more clear on the problem I'm having. I understand that those two values need to be set, I just can't figure out how to code them to be set.



When I try to apply values to those properties, I get the following error: "Object doesn't support this property or method". I know I'm just not doing it correctly, but I can't figure it out.



Here's an example snippet that I've tried to use:





function OnConnect() {

   window.ViewerX.Disconnect()

   window.ViewerX.HostIP = document.VNCViewer.Address.value

   window.ViewerX.Port = document.VNCViewer.Port.value

   window.ViewerX.UltraVNCSecurity.EnableSecurity = 1

   window.ViewerX.UltraVNCSecurity.KeyFilePath = "C:\rc4.key"

   window.ViewerX.Connect()

}





Also, I know the VNC server is fine because I can connect to it using the UltraVNC Viewer (properly configured).
Yury Averkiev (s-code)
Yury Averkiev (s-code)
Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)
Group: Administrators
Posts: 1.9K, Visits: 3.6K
I suggest you to try the following two things:



instead of EnableSecurity = 1, assign it to window.ViewerX.UltraVNCSecurity.EnableSecurity = true; This is a boolean property so you should use boolean values.



Another trick, is to replace ViewerX.UltraVNCSecurity.XXX calls with:

window.ViewerX.UVNCS_EnableSecurity = true;

window.ViewerX.UVNCS_KeyFilePath = "file path";

http://www.s-code.com/App_Themes/Default/images/blue_line.gif
Regards,
Yury Averkiev, SmartCode

Bonji
Bonji
Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)
Group: Forum Members
Posts: 10, Visits: 21
When I used true instead of 1, I got an error that true is undefined.



I was able to get beyond my error by using the UVNCS_EnableSecurity property and setting it to 1.



I have a new problem now in that I use MSLogon authentication and instead of getting a username and password prompt I only get a password prompt.



Thanks for your help!
Yury Averkiev (s-code)
Yury Averkiev (s-code)
Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)Supreme Being (213K reputation)
Group: Administrators
Posts: 1.9K, Visits: 3.6K
By default ViewerX tries to authenticate using VNC password authentication.

You should set property LoginType to 1, this will tell ViewerX to use NTLM authentication.

http://www.s-code.com/App_Themes/Default/images/blue_line.gif
Regards,
Yury Averkiev, SmartCode

Bonji
Bonji
Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)
Group: Forum Members
Posts: 10, Visits: 21
I should probably clarify...



I have ServerA which uses MSLogon authentication but not DSM encryption.

I have ServerB which uses MSLogon authentication and DSM encryption.



With EnableSecurity set to 1, I get a password-only login prompt no matter if I try connecting to ServerA or ServerB (and I know I can never successfully logon to ServerA since the encryption settings don't match).



With EnableSecurity set to 0, I get username and password login prompt on ServerA and a connection error on ServerB (which is what I would expect since the encryption settings don't match).



Basically, I'm pointing out that my MSLogon authentication is working on the server side, but enabling the DSM plug-in appears to prevent using it for authentication.
Bonji
Bonji
Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)
Group: Forum Members
Posts: 10, Visits: 21
By default ViewerX tries to authenticate using VNC password authentication.

You should set property LoginType to 1, this will tell ViewerX to use NTLM authentication.





It is set to 1. I got it working on a server that was not using encryption before trying the most complicated setup I had (which included encryption). Setting EnableSecurity to 1 changes the logon box to password only even with LoginType set to 1.
Bonji
Bonji
Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)Supreme Being (1K reputation)
Group: Forum Members
Posts: 10, Visits: 21
I was finally able to get it to work.  I was setting the security values in the function called when you click connect.  Although it does seem to do something, it appears to reset (or ignore?) the LoginType value.

When I changed it to set the security values inside the OBJECT tag (along with a lot of other properties), it did not reset the LoginType so I was able to successfully connect.

Thanks for your help.

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Explore
Messages
Mentions
Search